Google Apps Sync for Microsoft Office installation fails

January 9th, 2015

When installing the Google Apps Sync for Microsoft Office (GASMO) for Outlook, I often run into the issue that the installation fails with some “Service registration failed”. Apparently this is (or at least can be) an issue with mapi32.dll, and in my case has been caused by incomplete or erroneous Office installations (see my previous post). Solution? Fix that Office installation… In my case, it fixed GASMO installation right away…

MS Office 365 installation stuck at 76%

January 9th, 2015

While installing Office 365 (ProPlus) for some user, I often run into the issue that the setup hangs/freezes at 76%, while installing in the background. It never gets further and just sits there indefinitely. If I restart the machine (although the box tells me not to, “breakin’ the law!”) Office works fine and one thinks about what the last 28% are for. I can’t answer that… There are many sites discussing issues where the setup of Office 365 and 2013 gets stuck at some percentage, often mentioned as a culprit is something with Print Spooler if it hangs above 80% or disabling antivirus and whatnot, none which worked for me. I found one that mentioned 76% specifically and the closest I came to an actual error description was that some file in the online installation is broken/corrupted. However this is an online installation, where the install file is some small thingy, with the user’s data embedded.

Anyways, to remedy this, I first remove Office completely using the Office Removal Tool Fix It (link below), and then instead install with the Office Deployment Tool, which sounds more advanced than it is (at least for how I use it). With this, I skip the online installation stuff, and download complete installation first, and then install from that. The deployment tool uses a configuration XML file which tells where to store the download, which version to download, architecture (x86/x64) and can also do more I don’t know anything about.

Download the deployment tool here: http://www.microsoft.com/en-us/download/details.aspx?id=36778

The “install” gives you a file called setup.exe and a sample XML configuration file. The sample looks something like this:

<Configuration>
  <Add SourcePath="\\Server\Share" OfficeClientEdition="32" >
    <Product ID="O365ProPlusRetail">
      <Language ID="en-us" />
    </Product>
  </Add>
</Configuration>

SourcePath is where it’s going to save the downloaded material, OfficeClientEdition is the architecture (I presume) and the Product ID is the product in question (here Office 365 Pro Plus). I don’t know where to find these ID’s, google might. I changed the Language ID to “da-dk” for Danish.

Run the setup like this:

setup.exe /download <link-to-configuration-file>

which takes a year and a half downloading all the goodies.

To install run:

setup.exe /configure <link-to-configuration-file>

This gave me a clean install without issues! wtf?!


 

Download the Office Removal Tool here:

http://go.microsoft.com/?linkid=9815935